using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Integer""";
string input = @"Integer a = 3;
if(a > 5){
float b = 3.5;
}
while (a++){
a = a + 1;
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}