const regex = /^G[01](\h+X(-?\d*\.?\d+))?(\h+Y(-?\d*\.?\d+))?(\h+Z(-?\d*\.?\d+))?(\h+E(-?\d*\.?\d+))?(\h+F(\d*\.?\d+))?(\h*;\h*([\h\w_-]*)\h*)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^G[01](\\h+X(-?\\d*\\.?\\d+))?(\\h+Y(-?\\d*\\.?\\d+))?(\\h+Z(-?\\d*\\.?\\d+))?(\\h+E(-?\\d*\\.?\\d+))?(\\h+F(\\d*\\.?\\d+))?(\\h*;\\h*([\\h\\w_-]*)\\h*)?', '')
const str = `G1 X93.175 Y81.143 E0.70960 ; infill`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}