import Foundation
let pattern = #"proxy for task \[\K.+?(?=from job)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[13.04.2016 03:50:08] <15> Info [RTS] [ProxyLoadAnalyzer] Trying to get best proxy for task [DC-CTACWKSTN02.thenewsgroup.com from job "BC-Prod_Windows-Computac_Workstations_vApp" (task id:bcf87bf5-4692-4426-98cb-dab1b7d87091,"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}