use strict;
my $str = 'mary poppins 50th anniversary edition
the blues brothers 25th anniversary edition';
my $regex = qr/\d{1,2}.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";