$re = '/((\b00|\+)39[\. ]??)??3\d{2}[\. ]??\d{6,7}\b/';
$str = 'hello this is my number +39 3331111111 how are you?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);