import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d{3}_[a-zA-Z]+)(\\d{3}\\.jpg)";
final String string = "205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
+ "205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info].\n\n"
+ "321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
+ "321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info] \n"
+ "321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
+ " ...\n"
+ "321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n\n"
+ "205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
+ "205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
+ "205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
+ "205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]";
final String subst = "\\1_\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}