const regex = new RegExp('\\b(\\d{3}_[a-zA-Z]+)(\\d{3}\\.jpg)', 'g')
const str = `205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info].
321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
...
321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]`;
const subst = `\1_\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);