use strict;
my $str = '205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info].
321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
...
321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]';
my $regex = qr/\b(\d{3}_[a-zA-Z]+)(\d{3}\.jpg)/p;
my $subst = '\\1_\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";