#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)desc\s*"(((?!").)*)((?!\n).)*\n{1}task\s*:(((?!\n).)*)do(((?!\nend).)*)\nend"
Local $sString = "import 'cloud2/cloud2.rb'" & @CRLF & _
"desc "transfer db from current location to local and new dev"" & @CRLF & _
"task :fulldbtransfer => [ " & @CRLF & _
" :dbdown, :dbup, " & @CRLF & _
" :dbup_live,]" & @CRLF & _
"$comps_db = ['prube_yalecomps']" & @CRLF & _
"$tnew_dbs = [ 'prube_yaletnew_drama_prod'," & @CRLF & _
" 'prube_yaletnew_summer_cabaret_prod'," & @CRLF & _
" 'prube_yaletnew_cabaret_prod'," & @CRLF & _
" 'prube_yaletnew_music_prod'," & @CRLF & _
" 'prube_yaletnew_rep_prod']" & @CRLF & _
"$new_tnew_dbs = [ 'prube_yaletnew_drama'," & @CRLF & _
" 'prube_yaletnew_summer_cabaret'," & @CRLF & _
" 'prube_yaletnew_cabaret'," & @CRLF & _
" 'prube_yaletnew_music'," & @CRLF & _
" 'prube_yaletnew_rep']" & @CRLF & _
"all_erube_dbs = $comps_db + $tnew_dbs" & @CRLF & _
"desc "Transfer Database, complete with tunnel setup and teardown"" & @CRLF & _
"task :dbdown do" & @CRLF & _
" all_erube_dbs.each do |database_name|" & @CRLF & _
" cloud2_mysqldump do tunnel_host 'cumulus-www-master-pub.rs.lynch2.com'" & @CRLF & _
" tunnel_user 'www' db_host 'cumulus-db-master.rs.lynch2.com' skip_secure_auth true " & @CRLF & _
" db_user 'mysql'" & @CRLF & _
" db_pass 'mysql'" & @CRLF & _
" db_name " file_prefix 'SOURCE_'" & @CRLF & _
" ignored_tables ['cache','hits','debug','sessionvars','sessions']" & @CRLF & _
" end " & @CRLF & _
" end" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"task :dbsandr do" & @CRLF & _
" dbname = "prube_yalecomps"" & @CRLF & _
" bucket_prefix = "comps"" & @CRLF & _
" cloud2_sed do" & @CRLF & _
" source_file "db-tools/SOURCE_mysqldump_ dest_file "db-tools/CLOUD2_ " & @CRLF & _
" find_str [ ]" & @CRLF & _
"" & @CRLF & _
" replace_str [ ] end" & @CRLF & _
"" & @CRLF & _
" dbname = "prube_yaletnew_drama_prod"" & @CRLF & _
" bucket_prefix = "drame"" & @CRLF & _
" cloud2_sed do" & @CRLF & _
" source_file "db-tools/SOURCE_mysqldump_ dest_file "db-tools/CLOUD2_ " & @CRLF & _
" find_str [" & @CRLF & _
" 'prube_yaletnew_drama_prod', ]" & @CRLF & _
"" & @CRLF & _
" replace_str [" & @CRLF & _
" "prube_yaletnew_drama", ] end" & @CRLF & _
"" & @CRLF & _
" dbname = "prube_yaletnew_summer_cabaret_prod"" & @CRLF & _
" bucket_prefix = "summer-cabaret"" & @CRLF & _
" cloud2_sed do" & @CRLF & _
" source_file "db-tools/SOURCE_mysqldump_ dest_file "db-tools/CLOUD2_ " & @CRLF & _
" find_str [" & @CRLF & _
" 'prube_yaletnew_summer_cabaret_prod', ]" & @CRLF & _
"" & @CRLF & _
" replace_str [" & @CRLF & _
" 'prube_yaletnew_summer_cabaret', ] end" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" dbname = "prube_yaletnew_cabaret_prod"" & @CRLF & _
" bucket_prefix = "cabaret"" & @CRLF & _
" cloud2_sed do" & @CRLF & _
" source_file "db-tools/SOURCE_mysqldump_ dest_file "db-tools/CLOUD2_ " & @CRLF & _
" find_str [" & @CRLF & _
" 'prube_yaletnew_cabaret_prod', ]" & @CRLF & _
"" & @CRLF & _
" replace_str [" & @CRLF & _
" 'prube_yaletnew_cabaret', ] end" & @CRLF & _
"" & @CRLF & _
" dbname = "prube_yaletnew_music_prod"" & @CRLF & _
" bucket_prefix = "music"" & @CRLF & _
" cloud2_sed do" & @CRLF & _
" source_file "db-tools/SOURCE_mysqldump_ dest_file "db-tools/CLOUD2_ " & @CRLF & _
" find_str [" & @CRLF & _
" 'prube_yaletnew_music_prod', ]" & @CRLF & _
"" & @CRLF & _
" replace_str [" & @CRLF & _
" 'prube_yaletnew_music', ] end" & @CRLF & _
"" & @CRLF & _
" dbname = "prube_yaletnew_rep_prod"" & @CRLF & _
" bucket_prefix = "rep"" & @CRLF & _
" cloud2_sed do" & @CRLF & _
" source_file "db-tools/SOURCE_mysqldump_ dest_file "db-tools/CLOUD2_ " & @CRLF & _
" find_str [" & @CRLF & _
" 'prube_yaletnew_rep_prod', ]" & @CRLF & _
"" & @CRLF & _
" replace_str [" & @CRLF & _
" 'prube_yaletnew_rep', ] end" & @CRLF & _
"" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"desc "Send Database to tigard-dev-rds"" & @CRLF & _
"task :dbup do" & @CRLF & _
" upload_dbs "reston-dev-rds.aws.lynch2.com"" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"desc "Send Database to tigard-mail2-rds"" & @CRLF & _
"task :dbup_live do" & @CRLF & _
" upload_dbs "reston-live-rds.aws.lynch2.com"" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"def upload_dbs (dbhost)" & @CRLF & _
" $comps_db.each do |database_name| " & @CRLF & _
" cloud2_mysql do db_host dbhost" & @CRLF & _
" db_user 'mysql'" & @CRLF & _
" db_pass 'mysql'" & @CRLF & _
" db_name "mysql" sql_files ["CLOUD2_ end " & @CRLF & _
" cloud2_mysql do db_host dbhost" & @CRLF & _
" db_user 'mysql'" & @CRLF & _
" db_pass 'mysql'" & @CRLF & _
" db_name " sql_files ["erube_upgrade.sql"]" & @CRLF & _
" end " & @CRLF & _
" end" & @CRLF & _
" $new_tnew_dbs.each do |database_name| " & @CRLF & _
" cloud2_mysql do db_host dbhost" & @CRLF & _
" db_user 'mysql'" & @CRLF & _
" db_pass 'mysql'" & @CRLF & _
" db_name "mysql" sql_files ["CLOUD2_ end " & @CRLF & _
" cloud2_mysql do db_host dbhost" & @CRLF & _
" db_user 'mysql'" & @CRLF & _
" db_pass 'mysql'" & @CRLF & _
" db_name " sql_files ["tnew_erube_upgrade.sql"]" & @CRLF & _
" end " & @CRLF & _
" end" & @CRLF & _
"end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")