const regex = /(?<=\s)(ich|ja|das|für|und|nein|doch|bock|kopf|lust|schnell|weg|zug|frei|bald|echt|klar|laut|nass|süß|toll|witz|ziel|haar|haus|wort|zeit|schatz|funk|glück|kuss|maus|nacht|paar|rund|satz|tage|ufer|viel|wald|welt|zahn|zelt|bunt|dorf)(?=\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)(ich|ja|das|für|und|nein|doch|bock|kopf|lust|schnell|weg|zug|frei|bald|echt|klar|laut|nass|süß|toll|witz|ziel|haar|haus|wort|zeit|schatz|funk|glück|kuss|maus|nacht|paar|rund|satz|tage|ufer|viel|wald|welt|zahn|zelt|bunt|dorf)(?=\\s)', 'gm')
const str = `How many of you have a Colin Robinson in your life? Someone who drags out conversations for as long as they can after you say,
"I gotta go, dude." Someone who asks you for favors they never return. Someone who will talk so fast in rambling sentences that you can't get in a word edgewise when you are just talking to them.
An energy vampire? I think I finally got rid of my Colin Robinson today! (Image)
Quand tu es chauve, qu'il fait-5°c, et que tu as oublié ton bonnet. #memecredi (Image)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}