const regex = /\/[a-zA-Z0-9]{5}\/((images|scripts|styles).*|(filemanager|index|500|400)\.php|manifest\.appcache|favicon\.ico)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/[a-zA-Z0-9]{5}\\\/((images|scripts|styles).*|(filemanager|index|500|400)\\.php|manifest\\.appcache|favicon\\.ico)', 'g')
const str = `/md089/scripts/load.js
/md089/index.php
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);