package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<master>([a-zA-Z0-9_]*\.|))Sequence\((\s*|)((!?(?P=master))([a-zA-Z0-9_]*)\(([a-zA-Z0-9_\(\)\,=>\{\}\s]*)\)(\,\s*|\,\n|\,|()))*(\n|)\)\;
`)
var str = `this.Sequence(this.Delay(1));
this.Sequence(this.Delay(1),this.Delay(1));
other.Sequence(this.Delay(1)); other.Sequence(this.Delay(1));
other.Sequence(other.Delay(1));
this.Sequence(other.Delay(1));
Sequence(
this.Delay(1)
);
Sequence(
this.Delay(1),
this.Delay(1),
this.Value(1, 0, 1, (v)=>{}),
this.Value(1,0,1, delegate(v){}),
);
//coment
a = 1;
this.GetPosition();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}