// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^:]*):").unwrap();
let string = "line1:blabla:etcetc";
let substitution = "$1\\t";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}