const regex = /(\s[A-Z]\.).+?(?=(\s[A-Z]\.)|(\W?(Answer:)\W?))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s[A-Z]\\.).+?(?=(\\s[A-Z]\\.)|(\\W?(Answer:)\\W?))', 'g')
const str = `1. Question goes here:
A. Answer one
B. Answer two
C. Answer three D. Not indented Answer
Answer: B is correct`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}