using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d*\n(.*)\n([^\d].*|)";
string input = @"1
Mecca (مكة)
Trading hub and sanctuary in pre-Islamic Arabia; holy city to Muslims; current capital of Makkah Province, Saudi Arabia
2
Medina (المدينة)
Political seat of Muhammad, and first capital of the Rashidun Caliphate; current capital of Al Madinah Province, Saudi Arabia
3
Damascus (دمشق)
Capital of the Umayyad dynasty; current capital of Syria
4
Baghdad (بغداد)
Second capital of the Abbasid dynasty, and actual seat of Harun al-Rashid; current capital of Iraq
5
Najran (نجران)
Christian center in 5th-7th century Arabia; current capital of Najran Province, Saudi Arabia
6
Kufah (Ø§Ù„ÙƒÙˆÙØ©)
Second capital of the Rashidun Caliphate under Ali's rule; first capital of the Abbasid dynasty; city in modern-day Iraq
7
Basra (البصرة)
City in Iraq
8
Khurasan (خراسان)
Region corresponding to modern Afghanistan and northeast Iran
9
Anjar (عنجر)
City in Lebanon
10
Fustat (Ø§Ù„ÙØ³Ø·Ø§Ø·)
Old city of Cairo
11
Aden (عدن)
City in Yemen
12
Yamama (اليمامة)
Modern Najd region of Saudi Arabia
13
Muscat (مسقط)
Capital of Oman
14
Mansura (المنصورة)
City in Egypt
15
Bukhara (بخارى)
Modern day Buxoro, capital of Buxoro Province, Uzbekistan
16
Fez (ÙØ§Ø³)
Shared with Morocco, not buildable if they are in the game
17
Shiraz (شيراز)
Capital of FÄrs Province, Iran
18
Merw (ميرÙ)
Modern day Mary; capital of Mary Province, Turkmenistan
19
Balkh (بلخ)
City in Afghanistan
20
Mosul (الموصل)
City in Iraq
21
Aydab (؟؟؟؟؟)
22
Bayt Ras (؟؟؟؟؟؟)
23
Suhar (ØµØØ§Ø±)
City in Oman
24
Taif (طائÙ)
City in Saudi Arabia
25
Hama (ØÙ…اة)
Capital of HamÄh Governorate, Syria
26
Tabuk (تبوك)
Capital of Tabūk Province, Saudi Arabia
27
Sana'a (صنعاء)
Capital of Yemen
28
Shihr (Ø§Ù„Ø´ØØ±)
City in Yemen
29
Tripoli (طرابلس)
Capital of Libya
30
Tunis (تونس)
Capital of Tunisia
31
Kairouan (القيروان)
City in Tunisia
32
Algiers (الجزائر)
Capital of Algeria
33
Oran (وهران)
City in Algeria
34
Tangier (طنجة)
Shared with Morocco, not buildable if they are in the game
35
Casablanca (الدار البيضاء)
Shared with Morocco, not buildable if they are in the game
36
Marrakech (مراكش)
Shared with Morocco, not buildable if they are in the game";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}