import re
regex = re.compile(r"(?<!\be\.g)\.(?=\s+\p{Lu})", flags=re.UNICODE | re.IGNORECASE)
test_str = "cats, e.g. Barsik, are funny. And it is true. So,"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")