const regex = /(\+41)\s(\d{2})\s(\d{3})\s(\d{2})\s(\d{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+41)\\s(\\d{2})\\s(\\d{3})\\s(\\d{2})\\s(\\d{2})', '')
const str = `+41 11 111 11 11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}