import re
regex = re.compile(r"(\+41)\s(\d{2})\s(\d{3})\s(\d{2})\s(\d{2})")
test_str = "+41 11 111 11 11"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")