#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)uk\.co\.autotrader:autotrader-spring-boot-?.*:\"?\${?\K[a-zA-Z-]*"
Local $sString = "uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot-dependencies:"$autotraderSpringbootVersion"" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot-dependencies:$autotraderSpringbootVersion" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot-dependencies:$someothername" & @CRLF & _
"" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot-dependencies:2.3.0.1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot:${autotraderSpringbootVersion}" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot:"$autotraderSpringbootVersion"" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot:$autotraderSpringbootVersion" & @CRLF & _
"" & @CRLF & _
" "uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}"" & @CRLF & _
"" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot:2.3.0.1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(regex to find match upto dollar working)" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot.*:\"?\$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"$" & @CRLF & _
""$" & @CRLF & _
""${" & @CRLF & _
"${" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"\$\"?\{?" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(regex to find match of text following dollar sign)" & @CRLF & _
"uk.co.autotrader:autotrader-spring-boot(\$\"?\{?)[a-zA-Z]*" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"uk\.co\.autotrader:autotrader-spring-boot:(?=[\$\"?\{?])[a-zA-Z-]*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")