const regex = /uk\.co\.autotrader:autotrader-spring-boot-?.*:\"?\${?\K[a-zA-Z-]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('uk\\.co\\.autotrader:autotrader-spring-boot-?.*:\\"?\\${?\\K[a-zA-Z-]*', 'gm')
const str = `uk.co.autotrader:autotrader-spring-boot-dependencies:\${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot-dependencies:"\$autotraderSpringbootVersion"
uk.co.autotrader:autotrader-spring-boot-dependencies:\$autotraderSpringbootVersion
uk.co.autotrader:autotrader-spring-boot-dependencies:\$someothername
uk.co.autotrader:autotrader-spring-boot-dependencies:2.3.0.1
uk.co.autotrader:autotrader-spring-boot:\${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot:"\$autotraderSpringbootVersion"
uk.co.autotrader:autotrader-spring-boot:\$autotraderSpringbootVersion
"uk.co.autotrader:autotrader-spring-boot-dependencies:\${autotraderSpringbootVersion}"
uk.co.autotrader:autotrader-spring-boot:2.3.0.1
(regex to find match upto dollar working)
uk.co.autotrader:autotrader-spring-boot.*:\\"?\\\$
\$
"\$
"\${
\${
\\\$\\"?\\{?
(regex to find match of text following dollar sign)
uk.co.autotrader:autotrader-spring-boot(\\\$\\"?\\{?)[a-zA-Z]*
uk\\.co\\.autotrader:autotrader-spring-boot:(?=[\\\$\\"?\\{?])[a-zA-Z-]*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}