import Foundation
let pattern = #"uk\.co\.autotrader:autotrader-spring-boot-?.*:\"?\${?\K[a-zA-Z-]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot-dependencies:"$autotraderSpringbootVersion"
uk.co.autotrader:autotrader-spring-boot-dependencies:$autotraderSpringbootVersion
uk.co.autotrader:autotrader-spring-boot-dependencies:$someothername
uk.co.autotrader:autotrader-spring-boot-dependencies:2.3.0.1
uk.co.autotrader:autotrader-spring-boot:${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot:"$autotraderSpringbootVersion"
uk.co.autotrader:autotrader-spring-boot:$autotraderSpringbootVersion
"uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}"
uk.co.autotrader:autotrader-spring-boot:2.3.0.1
(regex to find match upto dollar working)
uk.co.autotrader:autotrader-spring-boot.*:\"?\$
$
"$
"${
${
\$\"?\{?
(regex to find match of text following dollar sign)
uk.co.autotrader:autotrader-spring-boot(\$\"?\{?)[a-zA-Z]*
uk\.co\.autotrader:autotrader-spring-boot:(?=[\$\"?\{?])[a-zA-Z-]*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)