re = /(?:\B(?!\w)|\b(?=\w))Data\[3\](?:(?<=\w)\b|(?<!\w)\B)/m
str = ' Data[3]=(uint8)Data[1];'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end