$re = '/^(user\d+)$/m';
$str = 'user1
clothes/jackets/cool-red-jacket-25';
$subst = "script1.php?username=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;