const regex = /(,|^)(?:age\s*(?:\(years\))?:\s*(\d+)\s*(?:years)?)(?=,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,|^)(?:age\\s*(?:\\(years\\))?:\\s*(\\d+)\\s*(?:years)?)(?=,|$)', 'gm')
const str = `h1,h2,h3
A1,age:15,hh
B3,age:10,fg`;
const subst = `\1\2 years`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);