package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]([a-zA-Z0-9.-]{0,8}[a-zA-Z0-9])?$`)
var str = `Men-777.99
M`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}