package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(public|private|protected|internal)?( )+class( )+([a-z_][a-z0-9_]*)( )*((:|,)( )+([a-z_][a-z0-9_]*)( )*)*{`)
var str = `public class NomeDaClass : Pai, Interface{
public class NomeDaClass {
protected class ClasseDaLoca{
internal class ClasseDaLoca : Img{
}((:|,)( )+([a-z_][a-z0-9_]*){1,})?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}