$re = '/(public|private|protected|internal)?( )+class( )+([a-z_][a-z0-9_]*)( )*((:|,)( )+([a-z_][a-z0-9_]*)( )*)*{/i';
$str = 'public class NomeDaClass : Pai, Interface{
public class NomeDaClass {
protected class ClasseDaLoca{
internal class ClasseDaLoca : Img{
}((:|,)( )+([a-z_][a-z0-9_]*){1,})?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);