re = /(public|private|protected|internal)?( )+class( )+([a-z_][a-z0-9_]*)( )*((:|,)( )+([a-z_][a-z0-9_]*)( )*)*{/i
str = 'public class NomeDaClass : Pai, Interface{
public class NomeDaClass {
protected class ClasseDaLoca{
internal class ClasseDaLoca : Img{
}((:|,)( )+([a-z_][a-z0-9_]*){1,})?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end