#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^#[0-9]*="
Local $sString = "#1=stuff" & @CRLF & _
"#2=more stuff" & @CRLF & _
"..." & @CRLF & _
"#123=even more stuff"
Local $sSubst = "<a href='$&'>$&</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)