package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#[0-9]*=`)
var str = `#1=stuff
#2=more stuff
...
#123=even more stuff`
var substitution = "<a href='$&'>$&</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}