use strict;
my $str = '#1=stuff
#2=more stuff
...
#123=even more stuff';
my $regex = qr/^#[0-9]*=/mp;
my $subst = '<a href=\'$&\'>$&</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";