const regex = /\d(?=(?:\D*\d){0,3}\D*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?=(?:\\D*\\d){0,3}\\D*$)', 'gm')
const str = `+36 6 41 88 75 22`;
const subst = `X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);