# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\\begin\{[^{}]*}(?:(?!\\(?:end|begin)).|(?R))*\\end\{[^{}]*}"
test_str = ("meh meh\n\n"
"\\begin{itemize}\n"
"\\item something1\n"
"\\begin{itemize}\n"
"\\item something1.1\n"
"\\item something1.2\n"
"\\end{itemize}\n"
"\\item something2\n"
"\\begin{itemize}\n"
"\\item something2.1\n\n"
"\\item something2.2\n"
"\\end{itemize}\n"
"\\end{itemize}\n\n"
"blah blah\n\n"
"\\begin{itemize}\n"
"\\item somethingelse1\n"
"\\item somethingelse2\n"
"\\end{itemize}\n\n"
"the end.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.