$re = '/((?:^|>)\s*)[^<>]+May[^<>]+(\s*(?:<|$))/';
$str = '<div class=\'byline\'>
<div>some excerpt</div>
geplaatst door
<span class="name">Author\'s name</span>
May, 2015
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);