using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!title\s*=\s*"")\b([^""=\s]+)";
string substitution = @"{\1}";
string input = @"title = ""It's an interesting title."",
title= ""Who's Afraid of Ms. Virginia Woolf?"",
title=""What a crazy title"",";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}