use strict;
my $str = 'title = "It\'s an interesting title.",
title= "Who\'s Afraid of Ms. Virginia Woolf?",
title="What a crazy title",';
my $regex = qr/(?!title\s*=\s*")\b([^"=\s]+)/p;
my $subst = '{\\1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";