package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\D*\d+(*SKIP)(*F)|\d+`)
var str = `foo123bar123baz123456abc1111def123456789`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}