// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\D*\d+(*SKIP)(*F)|\d+").unwrap();
let string = "foo123bar123baz123456abc1111def123456789";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}