using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=<a href)";
string substitution = @"hello";
string input = @"
<p>Aquí va la additional information:<\/p>\r\n<p>Es importante que el <a href=""https://en.wikipedia.org/wiki/Ali_Dia"">tío de verdad<\/a> no lea las chorradas que inventamos, que los de Ice Hockey están muy cuadrados y pagen pegar con los puños<\/p><p>Aquí van los <a href=\""https://en.wikipedia.org/wiki/Carlos_Kaiser_(footballer)\"">competition highlights<\/a> del tío (Historical Results)<\/p>\r\n<p>Bon diaaa<\/p>""},
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}