// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^.*?(IDC\w*)[\s\S]*?(?:$|(,\n.*$))(\n|$)").unwrap();
let string = " LTEXT \"Width\",IDC_WIDTH_TEXT,203,74,22,10
EDITTEXT IDC_WIDTH_IN,244,73,57,12,ES_AUTOHSCROLL | WS_GROUP
CONTROL \"Manually scale instances and paper\",IDC_RAD_PSCALE_KEYIN,
\"Button\",BS_AUTORADIOBUTTON | WS_GROUP | WS_TABSTOP,15,89,132,10
CONTROL \"Keep drawing instance scale 1.0\",IDC_RAD_PSCALE_AUTO,
\"Button\",BS_AUTORADIOBUTTON,15,104,123,10
CONTROL \"Keep drawing paper scale 1.0\",IDC_RAD_ISCALE_AUTO,
\"Button\",BS_AUTORADIOBUTTON,15,119,118,10";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}