$re = '/^(\+ ?|0{2} ?)(421|420)([1-9]\d{2} ?)(\d{3} ?)(\d{3})$/m';
$str = '+421915398727';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);