re = /^(\+ ?|0{2} ?)(421|420)([1-9]\d{2} ?)(\d{3} ?)(\d{3})$/m
str = '+421915398727'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end