#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\p{Lu})(?!.*(.)\1$)\p{Cyrillic}{3,}$"
Local $sString = "вася" & @CRLF & _
"ва" & @CRLF & _
"Ва" & @CRLF & _
"Вася" & @CRLF & _
"Васяя" & @CRLF & _
"" & @CRLF & _
"It's Cyrillic" & @CRLF & _
"It's minimum 3 letters" & @CRLF & _
"It doesnt have space" & @CRLF & _
"The last letters doesnt repeat, i.e Gabenn <- is wrong, Moneyy <- is wrong, beucase the last 2 letters are repeating" & @CRLF & _
"First letter is capital"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")