import Foundation
let pattern = #"^(?=\p{Lu})(?!.*(.)\1$)\p{Cyrillic}{3,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
вася
ва
Ва
Вася
Васяя
It's Cyrillic
It's minimum 3 letters
It doesnt have space
The last letters doesnt repeat, i.e Gabenn <- is wrong, Moneyy <- is wrong, beucase the last 2 letters are repeating
First letter is capital
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)