package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(.*?)(_Capital))?(.*?)_(State.*)`)
var str = `Bokaro_State_Jharkhand
Ranchi_Capital_State_Jharkhand
`
var substitution = "\4\2_\1\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}