#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<pre[^>]*?>((?:(?!pre>).|\n)*)<\/pre>)"
Local $sString = "<pre></pre>" & @CRLF & _
"<pre>text</pre>" & @CRLF & _
"<pre>" & @CRLF & _
"" & @CRLF & _
"text" & @CRLF & _
" <a></a>" & @CRLF & _
"" & @CRLF & _
"</pre>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")