using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<pre[^>]*?>((?:(?!pre>).|\n)*)<\/pre>)";
string input = @"<pre></pre>
<pre>text</pre>
<pre>
text
<a></a>
</pre>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}