package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).{0,3}//.{0,5}`)
var str = `ABCDEFGHIJK//MNOPQRST`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}