$re = '/\(([A-Za-z0-9\s\'=]+)\) (and|or) \(([A-Za-z0-9\s\'=]+)\)/m';
$str = '(Field1 = \'Value1\') and (Field2 = \'Value2\') and (Field3 = \'Value3\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);