const regex = /^(?!.*\b(\d+)\b.*\b\1\b) *[1-9]\d* *(?:, *[1-9]\d* *)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\b(\\d+)\\b.*\\b\\1\\b) *[1-9]\\d* *(?:, *[1-9]\\d* *)*$', 'gm')
const str = `992,1005,1007,992,456,456,1008
44,1005,1110
13, 44 , 1005, 10078
11,1203,6666
1,11,99,2222
3435
1234 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}